Gem install will_paginate using methods

2009-03-19  来源:本站原创  分类:Ruby  人气:1307 

rails plugin will_paginate paging installation method

My system is ubuntu.
Steps are as follows:
Set up at # will_pagiante on GitHub now add to my GitHub resources gem
gem sources-a http://gems.github.com

# Through the installation of a mislav-will_paginate to use will_paginate
gem install mislav-will_paginate

# In the project "config / environment.rb"
# Rails:: Initializer.run do | config |
# Can not ... at one of the statements included in
# End after

require "will_paginate"

# Some of the new version can also be added between
# Rails:: Initializer.run do | config |

config.gem 'mislav-will_paginate',: version => '~> 2.2.3',: lib => 'will_paginate',
: source => 'http://gems.github.com'

# End
So when using will_paginate will be an update of the resource through: source => 'http://gems.github.com' designation. No need to download plug-ins to the project.

The following method can be downloaded to the vendor / plugins Medium

Method 1: linux / /
To install git, the following command can be used to install the latest version of will_paginate plug-ins
Under script / plugin install git: / / github.com / mislav / will_paginate.git
The installation of the official website View more information
http://github.com/mislav/will_paginate/wikis/installation

Method 2: windows / /

Download Subversion, download page Address: http://subversion.tigris.org/servlets / ProjectDocumentList? FolderID = 91, the latest version of the current svn-1.4.5, download the latest version Address: http://subversion.tigris.org/files / documents/15/39559/svn-1.4.5-setup.exe after Subversion installed, and to ensure that svn.exe directory where% path% environment variable
Rails set up good works to enter the project, under the command line execute the following command to install
ruby script / plugin install svn: / / errtheblog.com / svn / plugins / will_paginate

Method 3:
Download TortoiseSVN, download address: http://tortoisesvn.net/downloads, the current latest version 1.4.6, download the latest version Address: http://downloads.sourceforge.net/tortoisesvn / TortoiseSVN-1.4.6.11647-win32-svn - 1.4.6.msi
TortoiseSVN is installed after the
Browser, type svn: / / errtheblog.com / svn / plugins / will_paginate visit
Then put in the window to the local will_paginate Export, and then copied to the vendor / plugins / will_paginate directory can be used

By-laws: TortoiseSVN official Chinese Station http://www.subversion.org.cn

相关文章
  • Gem install will_paginate using methods 2009-03-19

    rails plugin will_paginate paging installation method My system is ubuntu. Steps are as follows: Set up at # will_pagiante on GitHub now add to my GitHub resources gem gem sources-a http://gems.github.com # Through the installation of a mislav-will_p

  • Application gem install will_paginate 2010-02-24

    rails2.0 later versions no longer support rails1.2 the paginate pagination will_paginate plugin instead. Application in rails gem install will_paginate method (windows system): gem install mislav-will_paginate - source http://gems.github.com Successf

  • Gem install to put under the HOME 2009-03-23

    ~ /. bashrc add export GEM_HOME = ~ /. gems export PATH = $ PATH: ~ / .gems / bin Gem download and unzip ruby setup.rb - prefix = ~ /. gems - no-ri - no-rdoc cd ~ / .gems / bin ln-s gem1.8 gem The installation of Rails 2.3 gem install rack - no-ri -

  • Gem install mysql under Ubuntu solution error 2009-05-24

    when gem install mysql error: checking for mysql_query () in-lmysqlclient ... no checking for main () in-lm ... yes checking for mysql_query () in-lmysqlclient ... no checking for main () in-lz ... yes checking for mysql_query () in-lmysqlclient ...

  • ruby gems gem install does not configure the source 2010-05-29

    Very often, I heard that gem install equipment not on the package Even to themselves, and then local installation. In fact, we might first look at the source of their gems (and ubuntu apt-get or rpm yum source similar) gem sources -l If the display i

  • gem install mysql error solution 2010-06-02

    gem install mysql error solution gem install mysql error when: checking for mysql_query () in-lmysqlclient ... no checking for main () in-lm ... yes checking for mysql_query () in-lmysqlclient ... no checking for main () in-lz ... yes checking for my

  • gem install cassandra 2010-06-04

    As the project developed the database used in the cassandra, a brief description of the next client to connect rails installed cassandra cassandra database must first install the gem install json gem install thrift gem install thrift_client gem insta

  • install gem install mysql mac 2010-07-20

    sudo env ARCHFLAGS = "-arch x86_64" gem install mysql I tried many times before, obviously missing piece is not up and running, because Apple used the intel CPU must be informed when the installation system to install 64-bit mysql, also have som

  • Ubuntu executed gem install mysql problems and solutions 2010-08-11

    sudo gem install mysql Then get something beautiful like: ERROR: While executing gem ... (RuntimeError) ERROR: Failed to build gem native extension. Gem files will remain installed in / usr/lib/ruby/gems/1.8/gems/mysql-2.7 for inspection. Start that

  • gem install google-appengine was harmonized not? 2010-12-31

    No other gem install problem, install google-appengine have a problem. HoLin:webcurl holin$ gem install thin Building native extensions. This could take a while... Successfully installed thin-1.2.7 1 gem installed Installing ri documentation for thin

  • Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` 2011-05-06

    Environment: linux ruby1.9.2 rails 3.0.5 mysql2 0.3.2 Problems: Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` Solution: gem uninstall mysql2 then gem install mysql2 -v 0.2.7 Reference: http://stackoverflow.com/questions

  • rails3 the mysql configuration problem: Error: Please install the mysql2 adapter: `gem install activ 2011-05-10

    rails3 the mysql configuration: Problem: Error: Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` The solution: Open the Web project Gemfile (in the root directory of the project site), will gem 'sqlite3' (If the command is

  • Ubuntu on the gem install mongrel, mysql error 2011-03-18

    If on Ubuntu gem install mongrel, mysql error, and contains the following error message: Building native extensions. This could take a while ... ERROR: Error installing mongrel: ERROR: Failed to build gem native extension. Building native extensions.

  • Installing starling with Gem install error ERROR: http://gems.rubyforge.org/ does not appear to be a rep 2011-06-08

    starling is a ruby ​​to write open source message queue server, concrete, and installation can be found: http://www.ooso.net/archives/506 Today is a time of server installation starling the following exception. Simply the next solution. Executive gem

  • gem install设置源 2013-07-23

    gem install rails --clear-sources --source http://rubygems.org --no-rdoc --no-ri --verbose --clear-sources 清除原来的源 --source 指定新的源 --no-rdoc 不安装doc --no-ri不安装help --verbose显示下载安装回应的信息

  • sudo gem install bundler 失败 2013-08-24

    首先将 gem 的源换成 淘宝的. gem sources --remove https://rubygems.org/ gem source --add 'http://ruby.taobao.org/' 然后执行 sudo gem install bundler

  • gem install libv8 错误 2014-02-16

    G:\gems>gem install libv8-3.11.8.17.gem -l Temporarily enhancing PATH to include DevKit... Building native extensions. This could take a while... ERROR: Error installing libv8-3.11.8.17.gem: ERROR: Failed to build gem native extension. C:/RailsInstal

  • gem install invalid solution 2010-04-14

    Ruby was recently picked up some minor script and found need to use some of Gems, even install a total failure, the Internet to find the original version is too old local Gems result. View Gems version information gem env Download the latest version

  • gem install no such file to load - zlib problem solving 2010-05-16

    Today Ubuntu10.04 plan to upgrade after installing the gem rubygem results suggest that no such file to load - zlib error. Solutions, installing zlib1g and zlib1g-dev package, and then 1. Back to the ruby source directory / ext / zlib under 2. Ruby e

  • gem install jekyll HTTP Response 301 2014-09-18

    换个source gem update --system --source http://production.s3.rubygems.org